Вход в биллинг - Billing entrance - www.CardsharingServer.com

English forum section

Автор Тема: Tips for OsCam users  (Прочитано 2283 раз)

suma

  • Модератор
  • Ветеран
  • *****
  • Сообщений: 9188
  • Keep trying!
Tips for OsCam users
« : 10 Декабря 2017, 11:34:20 »
Based on the experience of certain users of our server with problems to set up oscam emulator, we've composed a small tutorial how to set up oscam emulator for newcamd protocol. Please don't try to set up oscam for cccam protocol, as they conflict with each other. Be sure to use oscam settings only for newcamd protocol!


If you use OsCam emulator with VU+ or similar receivers (does not matter, one tuner or 2 onboard), find FCC (Fast Channel Change) or FBC option in your firmware (mainly, it relates to VTI image) and disable it!
If it is enabled, it causes sending too many requests to the server, etc., it may also cause picture multiple freezes, no picture at all, etc.
OSCAM SET UP:
1. Use newcamd protocol for Oscam emulator (www.cardsharingserver.com --> My subscription --> Settings for newcamd protocol --> Settings for Oscam emulator
2. Download Oscam via feed of your receiver's firmware.
3. Check etc\tuxbox\config\oscam\ folder.
4. Initially, there are 5 files in the folder:
oscam.conf
oscam.provid
oscam.server
oscam.srvid
oscam.user
5. Be sure to delete the following files:
oscam.provid and oscam.srvid
Only 3 files shall be left in the folder (all with 755 c-mode) (total, 3 files):
oscam.conf
oscam.server
oscam.user
6. From www.cardsharingserver.com --> My subscription --> Settings for newcamd protocol --> Settings for Oscam emulator, copy and paste settings to oscam.server file as it is. Must look like this:
[reader]
label       = "main_cardsharing.cc_XXXXX"
protocol    = newcamd
key         = 0102030405060708091011121314
device      = servXX.com,XXXXX
user        = your login
password    = your password
group       = 1
audisabled  = 1
inactivitytimeout = 300

As a rule, there are 2 [readers] for one port - one is for main server, the other one is for backup server.
Copy and paste as many [readers], as there are in the billing settings available (depends on how many subscriptions you have).
After all this is done, restart your receiver and enjoy watching TV.
VU+Zero. 13E, 82.5E, 56E, Vip All, OpenPLI 6.0 image, OSCam: 1.20-unstable_svn. ALL POSTS WITHOUT SIGNATURE AND LOG-FILE will be ignored and deleted!1.mg_cfg here http://www.cardsharing.cc/index.php?topic=23717.msg58140#msg58140
2. ignore-priority.lists here http://www.cardsharing.cc/index.php?topic

Jogi

  • Старожил
  • ****
  • Сообщений: 377
Re: Tips for OsCam users
« Ответ #1 : 07 Января 2018, 01:40:17 »
Oh here it is (hard to find this thread in all this subfolders *g*)
As suggested I add some comments:
May I add some notes :)
oscam.provid, oscam.srvid(2) and also oscam.tiers are only used locally to identify and display Providers (PayTV name) and Services (channel names) in Oscam webinterface or monitor. Basically this files do not affect decoding, but on large files (slow receivers) they might lead to freezers and rule violation (delayed decoding). So basically to setup Oscam the 1st time: remove this files (and perhaps add them later). Newer versions of Oscam are capable to read Provider and Service-ID from transponder-stream and also optional store detections. This option is not working very well on many receivers, so you should check oscam.conf file, if you have an entry "read_sdt" and "write_sdt_prov": set the parameter to "= 0" (or remove the lines completely what has the same effect as 0 is default value).

oscam.conf, oscam.user and oscam.server are the required files for decoding, while only oscam.conf is required to run oscam at all. With oscam binary and oscam.conf the emulator should at least start and status and configuration should be accessible via webinterface using URL http://box-ip:8888. Otherwise see oscam.conf if there is a section [webif] with personal settings (especially httpport and httpallowed might block connection on default port 8888).

the location of Oscam configuration files depends on the box (operating system) and might be /etc, /usr/etc, /var/keys - or anywhere else *g*. If you have installed Oscam via a configuration tool (what should also install at least an oscam.conf-file) search your box for file oscam.conf or oscam.*
The optional files oscam.services, oscam.dvbapi and oscam.whitelist might interfere with decoding - if you have not setup this files on purpose for this cs-server remove them (settings you got from different cs-server most likely not fit for this server and the cards used here). Without this files Oscam uses default settings what should work on any channel. The oscam.services needed to be activated for a (cs-)reader or a username to be loaded, while oscam.whitelist and oscam.dvbapi are used if the files are available (and if you are using dvbapi-mode on your satellite-receiver as usually done, see Oscam-webinterface > Configuration > DVBApi. By Oscam defaults dvbapi-mode is not enabled).

For information about the Oscam parameters available go to http://www.streamboard.tv/wiki/Hauptseite > select language and see what parameters can be made in the configuration files. As mentioned: oscam.conf, oscam.user and oscam.server are required for decoding while the content of oscam.server can be downloaded from the Billing center > My subscription > Show settings for newcamd protocol > Settings for emulator Oscam. Additional parameters are only optional and not required in oscam.services - so simply copy the box and past the content to your oscam.servers.
Setting up Oscam the first time simply use the parameters that are marked as "parameter is required" on Oscam-wiki website. Additional files like oscam.dvbapi and/or oscam.services which can be used to setup priority and ignore lists are only for optimization and not required.

PS: even if decoding works, log into Billing center and make sure you do not find a message of rule violation in the sub menu "Connections history" after some minutes and perhaps again after 1-2 hours.

PS: add basic settings oscam.conf and oscam.user which MIGHT work for your box.
Basically it is setup to use DVB-API mode which is supported by many boxes. As default it is configured to dreambox.
If it does not work: open webbrowser and go to URL http://<ip-of-your-stb>:8888 (accessible if your LAN IP-address is in a range from 192.168.0.xxx to 192.168.255.xxx, otherwise modify oscam.conf-file)
Go to Configuration (menu at the top) > Go to DVBApi and select the right boxtype. If your box is not mentioned try all available and restart receiver after switching and saving configuration.

As already mentioned in initial post here: logon to the billing center > My subscription > Show settings for newcamd protocol > Settings for emulator Oscam >>> copy whole content of the box and safe it as oscam.server > copy oscam.server to your STB
Coolstream Tank using NeutrinoHD and Doscam(Oscam-like for CST-receivers) with VIP-Astra. Dual login on server_81 via Cable-ISP

Radionov123

  • Новичок
  • *
  • Сообщений: 1
Re: Tips for OsCam users
« Ответ #2 : 13 Января 2018, 19:44:07 »
Id o have a VIP all package. Oscam works on DM 8000 perfectly with all providers and channels, except HTB + on 36E.

Log:

2018/01/13 18:38:19 4D58AB6A c   (dvbapi) Demuxer 0 trying to descramble PID 3 CAID 0500 PROVID 060A00 ECMPID 1773 ANY CHID PMTPID 00CB VPID 012F
2018/01/13 18:38:20 4D58AB6A c      (ecm) user (0500@060A00/0B01/6593/13E:54C3382EF288316B4E9124D2C43D6B52): not found (502 ms) by "backup_server name.cc_port_no" (F/2/2/2) - Amedia Premium HD
2018/01/13 18:38:20 4D58AB6A c   (dvbapi) Demuxer 0 restarting decodingrequests after 1 ms with 1 enabled and 4 disabled ecmpids!
2018/01/13 18:38:20 4D58AB6A c   (dvbapi) Demuxer 0 no suitable readers found that can be used for decoding!

The server name in log is replaced. In reality It is correct and. Any ideas what is wrong ?

Thank ´s in advance.
Dreambox 8000HD, Opendreambox 2.0., Oscam 1.20 , Vip all

Jogi

  • Старожил
  • ****
  • Сообщений: 377
Re: Tips for OsCam users
« Ответ #3 : 14 Января 2018, 07:57:27 »
1st: do you have an oscam.whitelist, oscam.services or oscam.dvbapi file ? is the error the same starting Oscam without this config files ??
2nd: as several times recommended: use NEWCAMD protocol, not CCcam
3rd: from the logfile page in webif switch debug level to ALL - might be more usefull if problem still exists
4th: this thread is named "Tips for Oscam users" - do you see any helpful tip in your post ? so why do not start an own thread for your problem ??
Coolstream Tank using NeutrinoHD and Doscam(Oscam-like for CST-receivers) with VIP-Astra. Dual login on server_81 via Cable-ISP